SAP Knowledge Base Article - Public

2496674 - Connection Button Grey-ed out for C4C Outlook Add-in

Symptom

When Auto login is enabled, the login button stays in the state In Progress forever and is grey-ed out.

Cause

The Logon Request will never reach the authentication server as there is one already in the queue and it will stay in Status In Process.

Resolution

The following options can be used to resolve this issue.

[1] Increase AutologonTimer value

In the registry, navigate to the following key. HKEY_CURRENT_USER\SOFTWARE\SAP\Business ByDesign FrontEnd\CD\ClientConfig

Now modify the String value AutologonTimer. If the value does not exist, you need to create the same. By default, the value is 20000. The value is maintained in millseconds and the default value corresponds to 20 seconds.

While modifying, increase the timer value to 30000 or in some cases to 60000. Note, that this value is also applied in all cases and hence the add-in features may not be available for the time specified in the timer after launching Outlook.

[2] Disable Auto login

If the login button is always in the state In Progress, you can disable auto login using the following steps.

In the registry, navigate to the following key. HKEY_CURRENT_USER\SOFTWARE\SAP\Business ByDesign FrontEnd\CD\ClientConfig

Delete all values related to auto login. These are listed below.
•Autologon
•AutologonTimer
•CertLogon
•LoginDetails
•SSOLogon

Restart Outlook after deleting these values.

Keywords

KBA , SRD-CC-FED , Feeds , How To

Product

SAP Cloud for Customer add-ins all versions