SAP Knowledge Base Article - Public

2497782 - Error 'An identity with the same ID XXX already exists' While Replicating Employees

Symptom

You receive the error message 'An identity with the same ID XXX already exists' while replicating Employees from SAP ERP or SAP CRM.

Reproducing the Issue

  1. Go to Master Data Integration Work Center
  2. Select Employees
  3. Select a failed replication
  4. You see the error message 'An identity with the same ID XXX already exists' (Where XXX represents the ID in error message)

Cause

The error is caused because you are assigning a Business User ID already existent for the Employee being replicated.

You can check the same following the next steps

  1. Go to Application and User Management
  2. Select Business Users view
  3. Search for Business User XXX (Where XXX represents the ID from error message)
  4. You are able to find the Business User

Resolution

Maintain a different User ID in replication request. 

  1. Go to Master Data Integration Work Center
  2. Select Employees
  3. Search for the failed replication request
  4. Open it
  5. Maintain a different ID in field User ID

0090FAE68E561ED797B7D2F6AE0760D2.jpg

Keywords

KBA , LOD-CRM-ACC , Account , How To

Product

SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1711 ; SAP Hybris Cloud for Customer add-ins 1705