Symptom
"Please check the uploaded Event Reason Rules. Either the rules file is not uploaded, or it is incorrect" error when doing a Job Info and Comp Info Change via MSS.
Environment
Successfactors Employee Central - Job Information
Reproducing the Issue
- Go to Employee and do Take Action> Change Job information and Compensation Information
- Change any field and save (the error shows up when this field has a rule to derive event reason)
- Save the Transaction
- You will get this error:
Cause
Cause 1: Configuration issue
The major cause would be the rules are configured such that it will trigger/set an event reason on modifying data on a particular field.
The event derivation here is happening via rules, but the Provisioning option 'Enable Business Rules for Event Reason Derivation' is not enabled.
Also if you are deriving workflow via rules please check 'Enable Business Rules for Workflow Derivation' setting from provisioning.
In one instance the cause of this issue is because of data inconsistency in the job information record of the employee.
Cause 2: Data issue
Check the adHoc Audit report on the employee where you get this error and verify the end dates of records. Example:
start-date | end-date |
7/28/1999 | 5/30/2017 |
5/31/2017 | 6/30/2017 |
The end date of the last record is not set to 12/31/9999, this is a data issue as all latest record will have end date as 12/31/9999.
Resolution
To resolve the configuration issue, please enable:
- Enable Business Rules for Event Reason Derivation
- Enable Business Rules for Workflow Derivation
- Refer to KBA: 2396664, 2260431.
To resolve data issue:
- Do a full purge import of the Job History data
- Please refer to this KBA on how to do full purge import: https://launchpad.support.sap.com/#/notes/2317955
Keywords
Event Reason Error Please check the uploaded Event Reason Rules , KBA , LOD-SF-EC-JOB , Job Information , LOD-SF-EC , Employee Central , LOD-SF-EC-RUL , DO NOT USE - Business Rules & Event Derivation , Problem