Symptom
The following error is generated when Adding an Achievement:
OData Service Achievement Failed, Error Status: error, errorThrown: Bad Request
User null does not exist
* screenshots taken from demo environment *
Environment
- SAP SuccessFactors Performance & Goals
- Continuous Performance Management (formerly SuccessLine)
Reproducing the Issue
- Open Continuous Performance by selecting the Continuous Performance Home Page tile
- Click on +Add Achievement
- Name your achievement and save
- You get the error
Cause
This is caused by the deep link used for this custom tile. The deep link goes to the path xi/ui/successline/pages/index.xhtml?_s.crb=fQCiZHkpkx7%2bHv%2fVpVMYG6bdjtI%3d#/summary/
The problem with this link is that while it opens a null user for all employees who have no direct reports, thus causing the reported issue.
Resolution
- Go to Admin Center > Manage Home Page
- Scroll down to Continuous Performance and click on the Edit icon
- Click to Navigation
- Highlight the URL and delete
- Click on the Home dropdown, right click Continuous Performance, and select Copy shortcut
- Right-click on URL text box and select Paste
- Click Next, then Finish
Keywords
KBA , LOD-SF-CPM-FBK , Achievement Feedback, Get Feedback , Problem
Product
SAP SuccessFactors Performance & Goals all versions