SAP Knowledge Base Article - Public

2498708 - OData Service Achievement Failed, Error Status: error, errorThrown: Bad Request - Continuous Performance Management

Symptom

The following error is generated when Adding an Achievement:

OData Service Achievement Failed, Error Status: error, errorThrown: Bad Request

User null does not exist

* screenshots taken from demo environment *

Environment

  • SAP SuccessFactors Performance & Goals
  • Continuous Performance Management (formerly SuccessLine)

Reproducing the Issue

  1. Open Continuous Performance by selecting the Continuous Performance Home Page tile
    1. Open CPM tile.png
  2. Click on  +Add Achievement
  3. Name your achievement and save
  4. You get the error
    4. Error.png

Cause

This is caused by the deep link used for this custom tile.  The deep link goes to the path xi/ui/successline/pages/index.xhtml?_s.crb=fQCiZHkpkx7%2bHv%2fVpVMYG6bdjtI%3d#/summary/

The problem with this link is that while it opens a null user for all employees who have no direct reports, thus causing the reported issue.

Resolution

  1. Go to Admin Center > Manage Home Page
  2. Scroll down to Continuous Performance and click on the Edit icon
    6. Edit.png
  3. Click to Navigation

    7. Edit.png
  4. Highlight the URL and delete
  5. Click on the Home dropdown, right click Continuous Performance, and select Copy shortcut
    9. copy shortcut.png
  6. Right-click on URL text box and select Paste
  7. Click Next, then Finish

Keywords

KBA , LOD-SF-CPM-FBK , Achievement Feedback, Get Feedback , Problem

Product

SAP SuccessFactors Performance & Goals all versions