SAP Knowledge Base Article - Public

2499058 - Error While Merging Accounts "Merge cannot be saved as the accounts XXX YYY belong to the same hierarchy" Using Data Cleansing

Symptom

You get below error while Merging Accounts:

  1. Which belong to same parent Account or
  2. It has one such Account which is a single Account in Account Hierarchy

Error: "Merge cannot be saved as the accounts XXX YYY belong to the same hierarchy"

Reproducing the Issue

  1. Go to Data Cleansing work center
  2. Select New Merge
  3. Select required First/Second/Third Customer to Merge
  4. Select Action
  5. Select Initiate Merge

Cause

It is not possible to Merge the Accounts with the same Hierarchy. This is to avoid cyclic relationship which may result in endless loop.

Scenario:

Hierarchy:
Acc 1       – (top most)
Acc 11     – Acc1(parent)
Acc 111   – Acc11(parent)
Acc 1111 – Acc111(parent and single account)

e.g. If Acc 11 and Acc 111 (or) Acc 11 and Acc 1111 are participating in merge process, which would alter the Hierarchy and cyclic loop would occur. Hence Merge is not possible.

Resolution

This is expected system behavior.

Keywords

KBA , LOD-LE-BP-MRG , Business Partner Merge , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions