SAP Knowledge Base Article - Public

2499468 - Unable to acquire data from universe in Lumira Desktop

Symptom

  • Lumira desktop hangs when attempting to acquire data from a universe via the universe query panel

Environment

  • SAP Lumira Desktop 1.31.x
  • Microsoft Windows
  • BusinessObjects Business Intelligence (BI) 4.x

Reproducing the Issue

  1. File > New > Universe query panel
  2. Connect to the BI Platform
  3. Select Universe
  4. Select all objects in the universe query panel
  5. Click the "Finish" button

Cause

  • Lumira Desktop needs to be sized correctly in order to process large amounts of data

Resolution

  • Modify the following parameters in SAPLumira.ini file (<ROOT_DRIVE>:\Program Files\SAP Lumira\Desktop):
    • -Xmx1024m should be progessively increased from 4096m to 8192m
    • Original value: -XX:MaxPermSize=128M  New Value: -XX:MaxPermSize=512M
    • Original value: -Dhilo.maxvizdatasetsize=10000 New Value: -Dhilo.maxvizdatasetsize=500000
    • Original value: -Dhilo.biggermaxvizdatasetsize=10000 New Value: -Dhilo.biggermaxvizdatasetsize=100000
  • Please refer to the Lumira Sizing guide to ensure Lumira Desktop is sized correctly as per the system specification:
    https://archive.sap.com/documents/docs/DOC-53374

Keywords

Lumira Universe Data , KBA , BI-LUM-DIS , Lumira Desktop/Discovery , Problem

Product

SAP Lumira, desktop edition 1.0