Symptom
You submitted a Sales Document, e.g. Opportunity, for approval, but the approver did not receive an approval notification.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go the to Sales work center;
- Go to the Opportunities view;
- Open Opportunity XYZ (XYZ represents the opportunity ID);
- Press Actions -> Submit for Approval;
- There is no notification for the approver.
Cause
The approver does not have the necessary accesses to approve the opportunity.
You can check following the steps below:
- Go to the Administration work center;
- Go to the Business Tasks Management view;
- Search for Business Tasks generated for Opportunity XYZ;
- Select the Business Task generated;
- Open the Application Log ABC (ABC represents the Application Log ID);
- You see the below messages:
- Summary: 1 users failed to pass the authorisation check;
- Employees without sufficient access rights for the item;
- No employee has sufficient access rights.
Resolution
You need to provide Read and Write Access to the approver for the Opportunity XYZ.
- Go to the Administrator work center;
- Go to the Business Users view;
- Select User ABC (ABC represents the approver's user's ID);
- Press Edit -> Acess Rights;
- Go to Access Restrictions tab;
- Maintain Read and Write Access to the view Opportunities.
Keywords
Missing, not received , KBA , LOD-CRM-OPP , Opportunity Management , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions