Symptom
Time account balance not updated after As of Date is changed in Time Accounts portlet on Manage Time Off page
Environment
- SAP SuccessFactors Employee Central 2.0
- SAP SuccessFactors Employee Central
- v12 / People Profile (PP3)
Reproducing the Issue
Navigate to Manage Time Off page of the employee then change As of Date from Today to a future date and notice that the account balance remains unchanged.
Cause
A. Simulate Accruals setting on the Time Account Type is not enabled.
B. Time Account Type Eligibility Status of the users have been changed manually through Manage Data/Manage Time Off Structures
If user(s) are not eligible on the accruable period, no accruals would be posted by the system. Note: SAP does not recommend changing the eligibility status records manually. All updates to eligibility status records must be done through Data Management tool.
Product Support: See Internal memo for sample logs
Resolution
A. Enable Simulate Accrual setting on the time account type configuration where accruals are to simulated.
To enable simulation for the time account type:
1. Go to Admin Center > Manage Time Off Structures.
2. Search for Time Account Type then search for the Time Account Type to be updated (i.e. Vacation).
3. Click on Take Action > Make Correction then change Simulate Accruals from No to Yes and save the changes.
B. Update the eligibility status of the users via Data Management Tool. See KBA 2433014.
See Also
For further information on fields relevant for accruals, see Time Account Type section in Appendices Section of Employee Central Time Off Implementation Guide.
2433014 - How to Update / Correct Eligibility Status in Time Off
Keywords
future accrual balance, time account, time account type, simulate accruals, accruable period, null, INVALID_PERIOD, simulation, Manage Time Off, Time Account Details as of , KBA , LOD-SF-EC-TIM , Time Off , LOD-SF-EC , Employee Central , Problem