Symptom
- The sync file is sent SFTP, but Onboarding is not Picking up the file
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- Logon to SFTP
- Go to a folder where the sync files are sent
- View the Sync files
Cause
- The file' name and/or extension are incorrect
- SFTP credentials/folder do not match to settings in Super admin site/Features/"Foundation Import" feature
Resolution
The file' name and/or extension are incorrect:
- Go to Onboarding Super admin site/"Import/Export Settings" and download "FoundationImport" file
- Open the file in any text editor and find necessary section. For example for user sync, it will be "SuccessFactorsUserImport"
- Check the property "FileMask". Usually it will be like "{AccountName}_User*.csv" (example for user sync). {AccountName} is Onboarding instance ID and "*" is any symbols.
If your ONB instance ID is "MyONBInstance", the file name should be MyONBInstance_User01012021.csv or just MyONBInstance_User.csv
SFTP credentials/folder do not match to settings in Super admin site/Features/"Foundation Import" feature
Please compare SFTP credentials and folder in place where you set schedule for sync and in Super admin site/Features/"Foundation Import". If you see difference, please do changes in necessary place.
Keywords
Sf, Success, Factors, OBD, ONB, Onboarding, Permission, Sync, Foundation, Import, Ad, Hoc, Report, Adhoc, File, Stuck, SFTP, User, Delta, Corporate, Structure, Inbound, Login, Job, Integration , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , Problem