SAP Knowledge Base Article - Public

2501319 - Reason Status Missing for Custom Status of Opportunity

Symptom

You've created the Custom Status XYZ (XYZ represents the Customer Status ID) for Opportunities but you cannot assign a Reason Status when it is selected.

Reproducing the Issue

  1. Go to Sales work center;
  2. Go to Opportunities view;
  3. Open Opportunity ABC (ABC represents the Opportunity ID);
  4. Change the Status field to Custom Status XYZ;
  5. You don't have any options for Reason Status field.

Cause

You did not assign Reasons to the Life Cycle Status of the Customer Status XYZ in the Business Configuration activity Opportunities.

Resolution

  1. Go to Business Configuration work center;
  2. Go to Overview view;
  3. Open activity Opportunities;
  4. Click on Assign Reasons;
  5. Select the Life Cycle Status maintained for Customer Status XYZ;
  6. Add reasons.

You can check the Life Cycle Status of the Custom Status XYZ following the steps below:

  1. Go to Business Configuration work center;
  2. Go to Overview view;
  3. Open activity Opportunities;
  4. Click on Maintain Customer Status;
  5. Check the column Life Cycle Status for the Custom Status XYZ.

Keywords

KBA , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , How To

Product

SAP Cloud for Customer add-ins all versions