SAP Knowledge Base Article - Public

2501791 - Not possible to change the Default Value in Direction field of Phone call

Symptom

You are not able to change the default value in Direction field of Phone call

Reproducing the Issue

  1. Go to the Activities Work Center.
  2. Go to the Phone Calls view
  3. Click on New button
  4. Direction field in New Phone Call defaulted to 'Outbound'

Cause

This is the system Expected behavior

Resolution

Requirement should be possible through PDI/SDK, given the 'Direction' field is currently Write-enabled.

Please check for create scenario and remove the intiator_code in the Business Object or set the default value for the field to 'Inbound' , according to your Business requirement.

Keywords

KBA , LOD-CRM-ACT , Activities , How To

Product

SAP Cloud for Customer core applications 1705 ; SAP Cloud for Customer core applications 1708 ; SAP Cloud for Customer core applications 1711 ; SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711