Symptom
When the customer changes the name of a product via the Product Administration view, the new description does not update in the Opportunity Overview facet.
Reproducing the Issue
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Navigate to the Sales Work Center.
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Go to the Opportunities View.
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Select an existing opportunity / create a new opportunity ABC (ABC represents ID of document).
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Add a product to the document.
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Save.
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Navigate to the Products work center.
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Go to the Product Administration view.
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Select the Product added to the document.
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Edit the name.
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Save.
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Check the Opportunity again / Refresh the Products under the Products Facet.
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The Product Description has not been updated but the name has under the Products Facet.
Cause
The identifier column (link with navigation -> Products - Product) will read the master data at run time and show the maintained description, hence it shows the
latest description.
The editable text field Products - Description and non editable static text Overview - Products - Description will not be read from master data each time for performance reasons.
This is the data that is saved in the opportunity when the product was first selected in the opportunity or description that was manually changed by the user.
This is Standard Behaviour.
Resolution
To get the updated description in the text field too, remove this product from the opportunity and add it again.
Keywords
KBA , LOD-CRM-PRO , Products , Product Enhancement