Symptom
No E-mail for notification even though E-mail is subscribed for notification.
Reproducing the Issue
- Workflow rule with type ' Notification' is executed on document ABC(ABC represents document ID)
- Notification can be seen in the notification icon
- This notification has E-mail subscribed
- Now make changes to document ABC
No e-mail sent though the notification subscribed.
NOTE: Document represents Activities, Sales Documents like leads, opporuntunities etc and also Tickets.
Cause
When the document is initially created, corresponding notification is created as a result of the workflow trigger and email is sent to the user if he is subscribed for e-mail.
If user is updating and saving on already created document, then system will check if there is any Open notification, If yes then it will update the changes on already open notification. As there is no new notification created and the existing one is updated, email is not sent.
Resolution
This is expected system behavior.
Keywords
KBA , LOD-CRM-WKF , Workflow , How To