Symptom
When trying to assign business roles to a business user in the Edit Access Rights screen, not all the business roles are displayed
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center
- Access the Business Users view
- Select a user and click the Edit button, then select the Access Rights option
- Navigate to the Business Role Assignment tab
- Here, you only see a fraction of the business roles available in the system
Cause
From version 1702 onwards, a categorization was introduced, separating business roles into local or global business roles. Depending on the administrator's access rights and scope restrictions, they will be local or global (i.e. a local administrator will see only local business roles, while global administrators will see all business roles).
While creating a business role, is it possible to choose if it will be a local role or global role through the Scope field in the General tab of the business role. By default, the system determines the scope restriction (local/global) automatically, but it is possible to toggle the Select Scope Manually option to set it manually.
Resolution
What determines whether an administrator has local or global restriction, is the assignment of work center view SEOD_ADMIN_SETUP_WCVIEW - General Settings.
As such, to change this situation, it is either possible to assign this view to the relevant administrators, or to change the Scope restriction of the business roles.
Please note that a business role will be created as global scope only, if any of the work center views mentioned are not allowed or partially allowed in the Administrator -> General settings -> Work Center View Restrictions for Local Administrators view.
See Also
The recommendation can also be found in the help document: Restricting Access for Local Administrators
Keywords
business role, local, role, scope, administrator , KBA , business role , edit access rights , SRD-CC-IAM , Identity & Access Management , How To
SAP Knowledge Base Article - Public