SAP Knowledge Base Article - Public

2503342 - LMS: Successfactors.com is not responding due to a long-running script

Symptom

When trying to 'View Course Dates' in a catalog for a hundred of scheduled offerings, page becomes unresponsive and when trying to scroll down the page, error below is shown. This is happening regardless of the browser.

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Environment

B1705 and later versions.

Reproducing the Issue

1. From My Learning> Find Learning.

2. Enter your search word.

3. Click on 'View Course Dates' from the course.

Cause

'resultRowsPerPage' in Search Configuration is set to 500. This would tell the system to fetch for 500 records in one go which is not recommended as it would result to performance degradation.

Resolution

Change the value on 'resultRowsPerPage' between 10-20 by going to System Admin > Configurations > System Configurations > Search.

See Also

https://jira.successfactors.com/browse/LRN-19406

Keywords

unresponsive page, unable to scroll down the page, long-running script, page not responding , KBA , LOD-SF-LMS-CAT , Catalog , Problem

Product

SAP SuccessFactors Learning 1705