Symptom
After creating an Activity Plan and Routing Rules for Visits in your system to which a Survey 123 (123 represents the name of the Survey) is attached by a particular Organizational Unit 456 a different survey abc gets attached when you trigger the condition by creating a Visit.
Reproducing the Issue
Prerequisite: An Activity Plan and a Routing Rule were created for Sales Organization 789 and for a condition xyz. A Suvey 123 was attached.
- Go to the Visits work center.
- Go to the Visits view.
- Create a new Visit that matches the condition xyz.
- In the new Visit go to the Survey facet.
RESULT: the Survey 123 is not attached.
Cause
The Visit you created did not match the Organizational Unit 789.
1) When you define a rule with an Organizational Unit, this is valid only for those Organizations.
2) When you define a rule without any Organizational Unit, then it is valid for all objects created that match the conditions.
Resolution
Please change the routing rules Sales Organization to be the same as the Account Sales Organization.
Our recommendation is to define the rules as specific as possible for performance reasons. If you have rules maintained with no Organization, then these rules will be evaluated for all Visits and if the number of rules is higher, it leads to performance issue.
Keywords
KBA , LOD-CRM-ACC , Account , How To