SAP Knowledge Base Article - Public

2504068 - Error with 'Null or Empty Per Person UUID' or 'User Profile UUIDs are valid' (Check ID: NullOrEmptyPerPersonUUID / UserProfileUUIDValidationCheck)

Symptom

When running the Check Tool for Employee Central Core or Talent Intelligence Hub, issues for the checks "Null or Empty Per Person UUID" (NullOrEmptyPerPersonUUID) or "User Profile UUIDs are valid" (UserProfileUUIDValidationCheck) can be found.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors Talent Intelligence Hub

Cause

In 2016, the field "perpersonUUID" was added to the per_person table and its entity object to facilitate future suite integration. The perpersonUUID field is populated during the New Hire process with a unique and immutable id which is not available for reporting and is not exposed in any UI. For per_person records created prior to this change in 2016, the UUID field is empty. These empty UUID fields will be flagged as the user profile UUIDs must be valid and not a null value.

Resolution

The check result is expected and has no impact on existing processes. To resolve the error, first check your User Management Check Tool - Inactive users have employment information. See if the User ID related to the error above is there, then use the Quick Fix. After that run your Employee Central Core or Talent Intelligence Hub Check Tool again.

If the solution above didn't work, run the Initialize per person immutable id job in Provisioning. As a customer, you do not have access to Provisioning. Please engage a Certified Partner or Product Support to assist with this configuration.

If you do not have a Certified Partner, please create a case with Product Support with the following:

  • If the check is under Employee Central Core, please create the case under component LOD-SF-EC-PER
  • If the check is under Talent Intelligence Hub, please create the case under component LOD-SF-TIH-MIG
    • Please provide the below required details to process the job:
      • Data Center (URL of your login screen)
      • Company Instance ID (where to apply changes)
      • Username (for us to populate as the Job Owner)
      • Approval to run the job

Steps for Support or Certified Partners:

  1. Log in to Provisioning
  2. Select the company name
  3. Select Manage Scheduled Jobs
  4. Select Create New Job
  5. Populate the following details:
    • Job Name: person GUID
    • Job Owner: [username provided by customer]
    • Job Type: Initialize per person immutable id
    • Occurrence: Once
  6. Select Create Job
  7. Locate the job and under the Actions column, select Run It Now

After the job has been processed, customers can run the check tool again and the errors will be resolved.

TIH pre-migration Check Error - "User Profile UUIDs are valid" (UserProfileUUIDValidationCheck)

The above error in TIH pre-migraiotn check tool does not only refer to the error regarding invalid User Profile UUID, it can also refer to an invalid mapping with Role / Job Code / Position.

To identify this kidnly please follow the below 2 step process :

  1. First, cross check thta it is not due to invalid EC user data-

    a. Run the "Initialize per person immutable id" Job as mentioned above

    b. Clear the below errors with quickfix:
    · InconsistentAssignmentIdExternalsCheckExecutor
    · NullOrEmptyAssignmentID
    · PurgeOrphanUsersWithoutEmployments

    c. Check the User Ids mentioned in the check tool error in the Employee Export File (UDF) that the users are active (If the user is inactive, the system is flagging the issue that Competencies are mapped to inactive users and this would need ot be removed)

  2. Second, If the above error persists in the TIH pre-migration check even though the user data in EC is correct, cross chekc the below mappings -

    a. Is the Job Code or Job Role mapped to the user inactive ?

    b. If Job Code and Job Role a both active check the Position mappings next in the Manage Job Profile Content for the Particular user's Job Role. Click on the mapped Positions to the Job Code and you may receive an application error "An application error occurred. Please try again later, or notify support if the issue keeps occurring." This shows there is an issue with the "Position Extention" Entity.




c. Download Position Extension Entity file form "Import and Export" Tool. On the "Position Extension.csv" file, add a filter to "Position.Code" column and notice there would be (blanks) present. For all these records with "Position.Code" as (blanks), Delimit the records and import the file to remove these invalid mappings.

Keywords

per person UUID, GUID, ECT-51642, ECT-74230, Null or Empty Per Person UUID Check, check tool, User Profile UUID Validation Check, TIH migration, Talent Intelligence Hub, TIH pre-migratio check, Job Code, Role, Position Extension, Position, Employee Export, success factors, sf, sfsf, ISA-40914 , KBA , LOD-SF-EC-PER , Person Data (All Person Data Types) , LOD-SF-PLT-CHK , SuccessFactors Platform Check Tool , LOD-SF-TIH-MIG , Migration to Talent Intelligence Hub , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions