Symptom
When trying to rehire a Contingent worker as a Full Time (Permanent) Employee, the system does not allow you to use the same old user ID for the new permanent position
Environment
- SAP SuccessFactors Employee Central
- Contingent Workforce
Reproducing the Issue
- Try to rehire a contingent worker via Admin Center > Add New Employee
- After entering the details of the contingent user, the system will pop up a duplicate check, and select "Accept Match"
- If continuing the steps with the same "Old Username", the following error is seen:
The User Name already exists. Please enter a new unique value.
Cause
Employments are separate for contingent workers and regular employees. The same username cannot be used
Resolution
- A different username must be used other than the one existing on the system
- This applies for contingent to regular hire and vice versa
See Also
Keywords
SF, success factors, EC, CWF, user name, work force, ECT-66792 , KBA , LOD-SF-EC-CWF , Contingent Workforce , LOD-SF-EC , Employee Central , Problem
Product
SAP SuccessFactors Employee Central all versions