Symptom
- I-9 Reverification triggered for US citizen which is not expected.
- When will I-9 Reverification process kick start
Environment
All DC
Reproducing the Issue
Check the Super admin => account => Processes => Reverification process is enabled
Navigate to Super admin => account => manage HR data => search for the candidate => Reverification process is created for the candidate
Cause
Expected behaviour in exception scenarios
Resolution
In General , I9 Reverification process is not needed for US citizens but there are scenarios when documents submitted by US citizen are Damaged / Missed / Stolen. In these cases, We configure a Notification to intimate Candidate and manager (defined in Notification) thus I-9 Reverification is needed.
Sample email triggered for one such case:
Reminder email [ID=<unique system generated id>; Title=Send Lost, Stolen or Damaged Notification to Employee] sent to [<candidate email id>](CC=[<manager/recruiter email id>]).
For non US citizens , I9 Reverification is triggered 90 days before thier submitted docs are expiring. (check docs under List A , List B and List C)
Keywords
I-9 Reverification
US Reverification
US I9 Reverification
Reverification
90 days before Expiring , KBA , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , Problem