Symptom
A business rule has been configured for triggering alert and notifications for work orders. But it is not working.
Environment
- Employee Central: Contingent Workforce
- Employee Central: Alerts and Notifications
Reproducing the Issue
Cause
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Intelligent Services is not enabled
-
Off Cycle Event Batch has not been implemented
Resolution
Work Order alerts and notifications work in a different way than usual EC alerts and notifications. For work order alerts and notifications, Intelligent Services should be enabled in the instance. Use Upgrade Center for Intelligent Services.
Please note that the job owner of the job "Offcycle Event Batch Processing Job" must have permission to Work Order object. If the job owner does not have the permission, the alert will not be generated.
Once Intelligent Services is enabled, please refer to this section of the Contingent Workforce Management handbook.
See Also
Keywords
work_order, intelligent_services, contingent_workforce, ECT-58080, , KBA , LOD-SF-EC-CWF , Contingent Workforce , LOD-SF-EC , Employee Central , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem