SAP Knowledge Base Article - Public

2507127 - IDP Is Not Automatically Selected During SSO Logon

Symptom

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

You have configured Single Sign-On and when logging in via SSO, you are asked to select an Identity Provider from the dropdown menu, even though only one Identity Provider is maintained.

IDP Selection.png

Environment

  • SAP Cloud for Customer
  • SAP Business ByDesign

Reproducing the Issue

Launch the SSO url and you will be presented with SAP NetWeaver page to select the IDP

Cause

If Manual Identity Provider Selection is checked in the Configure Single Sign-On screen, this behaviour occurs.

Resolution

C4C supports multiple IDP's, so based on your requirement, you can check/uncheck the option "Manual Identity Provider Selection"  by following the below mentioned steps:

  1. Navigate to Administration work center
  2. Navigate to Common Tasks > Configure Single Sign-On
  3. Under My System,  find Manual Identity Provider Selection option

Keywords

SSO, Netweaver, login issue, Manual Identity Provider Selection , KBA , manual identity provider selection , SRD-CC-IAM , Identity & Access Management , How To

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions