Symptom
- Employee times were imported to the system, via import and export data > Import Employee Times
Some leaves for the same date and time type, are showing multiple times on the workbench, while other requests are not appearing at all:
If you export employee times and filter by this user, only one entry exists for this date.
- This can also affect the display on the Team Absence Calendar. For example, no users will show on the calendar for weeks where these employee times exists.
Environment
Employee Central
Cause
Employee times were imported with external codes that had “/” symbols included.
External code for example is “3074_02/27/2017” it should be 3074_02272017.
This confuses the system, and caused this error.
Resolution
For Employee Times:
It is not possible to edit the external codes for employee times via manage data / import.
Therefore you must cancel/delete the absences and recreate with correct external code (leave external code blank if using import, so system can generate correct external code).
*The same applies for the external codes on time types. If special characters are used here, it confuses the system and can cause errors.
For Time Types:
You need to rename the external codes for the affected time types, which you can do via import / manually via Manage time off Structures.
Keywords
Employee time external code,Duplicate leave requests,Missing leave requests,special characters, team absence calendar shows no users for some weeks, team absence calendar stops showing data, team absence calendar is empty , KBA , LOD-SF-EC-TIM , Time Off , Problem