SAP Knowledge Base Article - Public

2507386 - The Value Zero Disappears from Survey Question Fields 'Default Value' and 'Lower Limit'

Symptom

The value zero in the fields 'Default Value' and 'Lower Limit' disappears while you are trying to design a Survey.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Surveys work centre.
  2. Select the Surveys view.
  3. Click New.
  4. Select the Design facet.
  5. Click Add, to add a new question.
  6. Select question type Amount, Numeric Value or Quantity. 
  7. Enter a 0 (zero) into either or both fields: 'Default Value' and 'Lower Limit'.
  8. Click the OK button.

As soon as you click anywhere else, the zero value you entered vanishes. You see an information popup: "Enter a nonzero value".

Enter a nonzero value.png

Cause

This is a limitation in Surveys.

Resolution

If zero should be a valid response, contact the person who designed the survey. They may need to adjust the type or the upper and lower limits that are defined for this question.

Also, as a workaround to prevent negative values, lower limit can be set to "1".

See Also

SAP Help Centre:

Keywords

Survey design, create survey, Amount, Numeric Value, Quantity, null, 0, cannot, vanishes, missing, not possible, enter a nonzero value, nonzero value survey, nonzero value question, survey lower limit, question lower limit , KBA , LOD-LE-SUR-DEF , Survey definition = design time , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions