Symptom
Performance forms appear to be stuck in the old manager's inbox, and won't move to the new manager's inbox using either Employee Import manager transfer options or Document Transfer Tool
Environment
SAP SuccessFactors Performance & Goals
Reproducing the Issue
- Form is in previous manager's inbox
- moving the subject back to previous manager, then moving to new manager with Automatic Inbox Document Transfer option enabled
- Form is still in previous manager's inbox after second import
- Using Transfer Forms to New Manager tool doesn't work either, and reports that "forms transferred successfully"
Cause
This happens when the following conditions are met:
- The initial manager transfer did not have any document transfer options done
- The previous manager has a valid role, such as the new manager's manager (EMM)
What happens then is that the current step -- which used to be a manager (EM) step, has become converted to the previous manager's new role (EMM). Any document transfers will just move the form at that level -- in this example, between managers' managers.
Resolution
Since manager transfer options no longer work, the best workaround is to use Modify Form Route Map to add a new manager (EM) route step. Follow these steps:
- Go to Admin Center
- Select Manage Forms by User > Modify Form Route Map
- Enter the form ID of the affected form
- click the Plus icon at the Modify Stage
- Name the new step
- Set the Role as Manager
- Click Show advanced options...
- Set the step ID to be the same as the current step
- Move the new setp to just below the current step (move the mouse cursor over the number. Six dots should appear; move your cursor over those dots and drag the step to the correct order)
- Click on Next
- Route the form to the next step either by proxying as current form owner and moving to next step, or by using Route Form in Admin Center
Keywords
KBA , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , Problem