SAP Knowledge Base Article - Public

2508568 - Options missing for Event in Workflow Rule

Symptom

You are trying to create a Workflow Rule with Business Object Account and Timing Scheduled > Event and are unable to access the drop down options in Event which is not allowing you to save the Workflow Rule.

Reproducing the Issue

1. Go to Administrator workcenter

2. Go to Workflow Rules

3. create a Workflow Rule with:

  •  Business Object: Account
  •  Timing: Scheduled

-> the option to select an Event for the Timing becomes available but the drop down menu is empty

Cause

In the Event field, the fields which come up are of type "Date" or "Date/Time".

For the Business Object Account there is no standard field of type "Date/Time" being exposed in the Workflow Rule.

Resolution

In order to use the Scheduled feature, you must have an extension field in the Account Business Object of type "Date/Time" and you should use that field in the "Event" field.

The Workflow Rule will trigger whenever the value of that extension field will change.

 

Please note that the value of the extension field should lie ahead of the time of the change. For example, if you are changing the extension field's value created above at 10:00 AM, then its value should be ahead of 10:00 AM on the same day, or at a future date.

If you don't want to use the Scheduled feature, you can also use the "On Every Save" Timing option, and define some conditions on which only the action should trigger.

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711