Symptom
When you try to add fields related to Account Address, such as Email, Phone Number, House Number, to be used as placeholder for Workflow Emails, you cannot find them.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Administrator work center.
- Workflow Rules view.
- Open workflow rule ABC (ABC represents the ID of the Workflow Rule).
- On Step 1, select Business Object as Account.
- Go to Step 3, Define Actions.
- Select Email on the Action field.
- On the Placeholders section, click Add Row.
- See that fields Email, House Number, Phone Number are not available.
Cause
Not all fields are available to be selected as placeholders.
Please note the available fields are dependent of the BO you choose the workflow rule for.
Resolution
This is the expected system behavior.
If you need the object ID urgently in the Related Items facet of tasks you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
You can find more details about the services offered by the Cloud Service Center on https://www.sap.com/services/application-development.html .
You can contact the Cloud Service Center as follows:
- If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.
- If you are a customer: please use the little blue box “Contact Us” shown on the very right-hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page.
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Hybris Cloud for Customer Ideas Forum to submit an idea: https://ideas.sap.com/SAPCloudforCustomer
Keywords
add fields, Account Address, Email, Phone Number, House Number, placeholder, Workflow Emails, e-mails , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-SRP , Service Request Processing , How To