Symptom
No Message Icon is displayed on the "My Profile" page of the Mobile Application
Environment
Employee Central
Mobile Application
Reproducing the Issue
When viewing the mobile application, navigate to the "My Profile" page of the Application
The My Profile page will load but No Message Icon is displayed on the "My Profile" page of the Mobile Application
Cause
The information is not being displayed as the user does not have the correct "View" permissions enabled in the appropriate Permission Role in the instance.
Also ,Please could you find out if the user has a phone number entered. If the user doesn't have any phone number on his profile, the message and phone icon will not appear on the profile page.
Resolution
This a permission configuration issue.
The related permission role must be edited to include view permissions for the related information.
To see the users information, for instance, the user's Message Icon in the My Profile page, the appropriate "View" permission must be enabled.
The Permission role must have a Target Population of Granted Users (Self) as in the below screenshot, in order to see the user information on their own profile page.
NB:
Go to the APP Store and update your SuccessFactors App.
Also see KBA 2284879
Keywords
Mobile Application
Mobile Permission Information Name Email Not displaying My Profile User Role Based Permissions RBP Information
Mobile Permission Information Cell or Business Phone Not displaying My Profile User Role Based Permissions RBP Information
Successfactors App is out of date
MOB-18294 , KBA , LOD-SF-EC-MOB , Employee Central Mobile , LOD-SF-EC , Employee Central , LOD-SF-FWK-MOB , Mobile Application , Problem