SAP Knowledge Base Article - Public

2513629 - Custom Tile not Avaialble for all Users on Home Page

Symptom

Custom tiles added to the home page DEFAULT role are not visible for all users

Reproducing the Issue

Steps are slightly different between HTML5 and Response UI clients. This document will give the steps on Responsive UI.

  1. Go to the Home Page;
  2. Click on the pencil icon to Edit;
  3. Select Adapt;
  4. Select the DEFAULT role and click on Go;
  5. Click on one of the empty tiles to Open App Finder;
  6. Select Create Custom Tile;
  7. Fill in the fields as desired;
  8. Click on Save;
  9. Click on Publish;
  10. Click on Leave Adapation Mode.

Now, log in with User XYZ (XYZ represents the User ID):

  1. Go to the Home Page;
  2. Click on the pencil icon to Edit;
  3. Select Personalize;
  4. Click on one of the empty tiles to Open App Finder;
  5. On the Custom tab, try to find the newly created tile;
  6. It is not avaialble.

Cause

User XYZ is assigned to a Business Role. The DEFAULT role on Home Page is meant to create data for all users that do not have any business role assignment.

Resolution

To have the custom tile avaialble to all users, you need to create it for every and each business role.
To have it avaialble for users with no business role, you create for the DEFAULT role.

Keywords

KBA , home page , default role , AP-RC-UIF , C4C UI Framework , How To

Product

SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711