Symptom
In your test system (source system), you have created a report or data source which in turn uses a PDI data source. Then you download it via the Analytics key user tools. When you try to upload it in the production (target) system, you get numerous errors like these:
'Data type of data source field XYZ is not available'
In Cloud for Customer, you will see these errors in Transport Management.
Disclaimer: "Images/data in this KBA are from SAP internal systems, sample data or demo systems. Any resemblance to real data is purely coincidental"
Environment
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SAP Cloud for Customer
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SAP Business ByDesign
Reproducing the Issue
Example steps in Business ByDesign:
- Go to the source system.
- Go to the Common Tasks in the Business Analytics work center.
- Select Download.
- Download the report or data source which you have created.
- Go to the target system -> Common Tasks in the Business Analytics work center.
- Select Upload.
- Upload the file you have previously downloaded and click on Save.
You will receive the mentioned errors.
Cause
In your source tenant, you created the data source / report which is based on a PDI data source with a different namespace to the one from the target tenant. So the solution namespaces of the data sources are not in synch in the source and target system - The source tenant has the data source with the patch solution namespace and the target tenant has the data source with the original solution namespace. This is the reason for the error messages.
To illustrate this on an example:
Note: The terms Y123_, Y456_, Y456_ABC are dummy
Source System | Target System |
Original Solution Y123_
|
Deployment of Original Solution: Y123_
|
Create a custom report / data source that is using Y456_ABC |
|
Download this report data source. The XML now contains references to Y456_ |
|
Upload this file in the target |
The system does not recognize references to Y456 since this solution ID does not exist in the target. Hence you get an error with reference to Y456_. |
Resolution
This is the correct behaviour - an upload is only possible if the target system also contains the same solution with the same namespace.
However, you can apply a workaround: Please ensure that in the test system, both the patch as well as the original solution have the same version. This will mean that they both have the same content. Then, when you go to the system and create your Z data source / report, you can select the object with the original namespace. This new object can then be downloaded and uploaded to the target system - this will be successful since the namespace is the same.
See Also
For more details on namespaces and PDI solution lifecycle management, please see the following blog:
https://blogs.sap.com/2015/08/27/sap-cloud-applications-studio-deployment-landscape-basics/
The section "PHASE 4: Life-cycle for patching and bug fixing" describes how to ensure the same namespace is used in both systems.
Keywords
Name Space, namespace, PDI, upload, extension fields, common tasks, Report, AP-RC-ANA, Solution, Data source, transport management , KBA , report upload , upload error , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To