Symptom
- Recruiter sees a new application of an intenal candidate with all necessary information filled in
- Once the recruiting user clicks into the application, the phone number disappears
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Candidate enters their phone number during the application process
- Recruiter goes to the new application on the job requisition and see the phone number filled in
3. Recruiter accesses the application and the phone number disappears permanently - appears 'not provided'.
Cause
There are two configuration checks you can make:
1. The fields are sm-mapped - hence it only affecting internal candidates:
- The Candidate Profile field 'cellPhone' is mapped to the Succession Data Model field 'businessPhone'.
- Recruiting users have been granted 'write' permission to cellPhone in the Candidate Profile but not in the Data Model
- sm-mapping requires the same permissions to be granted in both templates
2. In the data model, 'read' permission was granted to the field 'businessPhone', but the role name was left blank:
3. The sm-mapped field is blank in the candidate profile and the value is supplied during the application. When generating candidate snapshot (opening the application for the first time), the system syncs these candidate profile fields in the candidate snapshot in application.
Resolution
Product Support can look for:
- Make sure that the same permissions are granted for sm-mapped fields
- Check the fields in question for missing information such as description, role name etc
It will be the job of the Implementation Partner / Partner Consultant to make any necessary configuration changes.
Keywords
SF, Success Factord, RCM, sm-mapping, Field appears blank, candidate snapshot, cell phone, contact, CheckCandProfileForWarnings , KBA , LOD-SF-RCM , Recruiting Management , Problem