SAP Knowledge Base Article - Public

2514861 - How to Remove Workflow Scheduled Pending Actions

Symptom

When a workflow rule has been triggered which has some scheduled actions, it shows the future pending action in the workflow rule queue.
You want to know how to cancel or remove scheduled pending action that shows in workflow log.

Reproducing the Issue

  1. Go to Administrator Work Center
  2. Go to Workflows Work Center View and Check for rule XYZ which is de-activated.
  3. Click on the gear Icon/Cog wheel on the top right corner above the Search area.
  4. Choose "Wokflow Log".
  5. In the logs, you will see 2 sections , "Past Rules" and "Scheduled Rules".
  6. You can see future schedule of rule XYZ even after the rule XYZ has been de-activated.

Cause

According to workflow implementation, Condition evaluation of a given Workflow occurs twice:
1. While creating entry in queue BO.
2. While actual execution of workflow rule.

Due to the above, you will see the furture schedule of the rule available even if you de-activate a given rule. But this is not necessary that this schedule will execute at all times.

Resolution

There are many ways in which you can abort execution of scheduled workflow rule:

1. You can do appropriate change in field of application instance on which condition is maintained.
See the below example:-

Lets say for workflow rule Ticket: ABC condition is Ticket Type = DEF and Status = XYZ.
So you can make appropriate changes in the field Ticket Type and Status , So that it should not suffice condition at the time of actual execution.
If condition will not suffice the scheduled rule will not get executed.

2. If you want that all the scheduled entry of workflow rule "ABC" should not execute in future then Delete/Deactivate the workflow rule.
Deletion of workflow rule is possible.

  • Go to Administrator Work Center
  • Go to Workflow Rules and choose Deletion button in Action column for each workflow rule. ( Entry will be still present in scheduled log screen but since condition will not suffice at the time of execution so rule will not get executed ).

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer add-ins 1905 ; SAP Cloud for Customer core applications 1708 ; SAP Cloud for Customer core applications 1711 ; SAP Hybris Cloud for Customer add-ins 1705