Symptom
When a workflow rule with scheduled actions is triggered, the pending future actions appear in the Workflow Rule Queue.
You want to understand how to cancel or remove these scheduled pending actions from the workflow log.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Navigate to the Workflows work center view.
- Locate and select the workflow rule XYZ, which is currently deactivated.
- Click on the gear icon (cogwheel) located at the top right corner above the search area.
- Select Workflow Log from the dropdown menu.
- In the log view, observe two sections: Past Rules and Scheduled Rules.
- In the Scheduled Rules section, you can still see the future scheduled execution(s) of rule XYZ, even though the rule has been deactivated.
Cause
According to workflow implementation, Condition evaluation of a given Workflow occurs twice:
1. While creating entry in queue BO.
2. While actual execution of workflow rule.
Due to the above, you will see the future schedule of the rule available even if you de-activate a given rule. But this is not necessary that this schedule will execute at all times.
Resolution
There are many ways in which you can abort execution of scheduled workflow rule:
1. You can do appropriate change in field of application instance on which condition is maintained.
See the below example: -
Let's say for workflow rule Ticket: ABC condition is Ticket Type = DEF and Status = XYZ.
So, you can make appropriate changes in the field Ticket Type and Status, so that it should not suffice condition at the time of actual execution.
If condition does not suffice the scheduled rule will not get executed.
2. If you want that all the scheduled entry of workflow rule "ABC" should not execute in future then Delete/Deactivate the workflow rule.
Deletion of workflow rule is possible.
- Go to Administrator Work Center
- Go to Workflow Rules and choose Deletion button in Action column for each workflow rule. (Entry will be still present in scheduled log screen but since condition will not suffice at the time of execution so rule will not get executed).
Keywords
Workflow, Scheduled Action, Queue, Past Rules, Entry , KBA , LOD-CRM-EMP , Employee , How To
SAP Knowledge Base Article - Public