Symptom
When creating a Job Requisition from Position Org Chart or OData API Integration, an error message regarding the field "location", "division" or "department" appear:
- location invalid, with the index 0
- division invalid, with the index 0
- department invalid, with the index 0
Environment
SAP SuccessFactors Recruitment Management
Reproducing the Issue
- Go to Company Info > Position Org Chart
- Select the Position > Create the Job Requisition
- Get the above error message.
- If the position has a location/division/department where no employee is assigned then the error occurs.
- If the location/division/department value for the position has an active or inactive user in the database, there is no error.
Cause
-
The value of the fields "location", "division" or "department" does not exist in the User Data File (UDF), or the spelling or capitalization is different.
In the RCM module, the Enum standard fields "department", "division" and "location" have their values automatically coming from the values present in the corresponding fields on active or inactive users in the BizX user database. Therefore, the value must also be linked to a user in the User Data File. - The value retrieved from the Position is incorrect when using the Position Management Integration.
Resolution
Review the location/division/department value in the User Data File:
- Navigate to Admin Center > Employee Export.
- Click Export User File.
- Open the file and search for the value in the corresponding column (LOCATION / DIVISION / DEPARTMENT).
a. If the value exists, check the spelling and the capitalization. Make sure that the same value is passed when using Position Management Integration or OData API integration.
- The values are in the format "ExampleName (ExampleCode)". The value to be passed can be one of the followings: "ExampleName" or "ExampleCode" or "ExampleName (ExampleCode)".
- When using Position Management Integration, if the value will be mapped with the corresponding field from a position, please refer to the sample rule of "location" in the User Assistance Guide Integrating Recruiting and Employee Central Position Management to create the rule expression; If the exact value will be specified in the rule, the value should follow the above mentioned formats.
Other points to check:
(1) Make sure that there are no leading spaces or trailing spaces.
(2) Make sure that there are no non-breaking spaces (nbsp).
A non-breaking space can occur when you copy and paste formatted values into UDF. These spaces may appear as regular spaces in editors like Excel. You can remove it by simply deleting the space.
To remove it using "Find and Replace" function in Excel, hold down the ALT key and type 0160 in the "Find What" field, then enter a regular space in the "Replace with" field.
b. If there is currently no user in this location/division/department, a dummy user account can be created in order to use the value.
Assign the location/division/department value to a dummy user:
- Add a dummy user in the User Data File. The user status can be either inactive or active.
- Assign the location/division/department value in the corresponding column. The format is "ExampleName (ExampleCode)".
- Navigate to Admin Center > Import Employee Data.
- Select Basic Import.
- To create or update an inactive user, make sure to select the 'Process inactive Employees' checkbox in 'More Options...'.
- Select the file and import.
Keywords
SF, Success Factors, RCM, can't create, location invalid, department invalid, division invalid, Position, API, OData, Integration, COE0018 , KBA , LOD-SF-RCM-POS , Position Integration , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-JOB , Job Postings & Requisitions , Problem