SAP Knowledge Base Article - Public

2516322 - Incoming Message to Created 3PL Outbound Delivery Failing

Symptom

Incoming message from warehouse provider is not creating 3PL Outbound Deliveries.

Reproducing the Issue

  1. Go to Application and User Management work center.
  2. Select Business Communication Monitoring view.
  3. Select Rejected Web Service Calls for Show field.

Notice that there are failed messages:

Service Interface: Outbound Delivery Execution In

Direction: Incoming

Cause

If Ship-To Location is provided in the ODEC XML, then country code and region code tags must not be empty.

Resolution

To avoid the error, these 2 key fields have been made mandatory. The reason behind this system behavior is, later in Finance, these 2 information's are mandatory for calculating taxes.

You can get in touch with your 3PL provider. There are 2 options to fix it:

  1. Either do not send the ship-to location altogether. If it is not sent, system will auto determine it from predecessor documents.
  2. If they still want to send the ship-to location data, then the mandatory fields of country and region code must be filled. If there is the line <ShipToLocation> in the XML, then the Country Code and Region Code are mandatories. You need to update the lines </CountryCode> or </RegionCode> in the </ShipToLocation> tag.

Keywords

KBA , 3pl outbound deliveries , outbound delivery execution in , ship-to location , AP-IDP , Inbound Delivery Processing , How To

Product

SAP Business ByDesign all versions