Symptom
Why are specific email triggers not received automatically by a user while others are triggered and received with no delays?
Environment
SAP SuccessFactors Recruiting Management
Cause
The Recruiting Email Trigger functionality allows you to set up emails that will automatically be triggered upon a specific action. This will be triggered everytime once it is enabled and its trigger cannot be customized.
This feature was introduced in b1308 and additional triggers are added with each product release, along with the option to modify the content of the email templates. However, each trigger has its specific trigger point and may be sent to recipients in a Synchronous or Asynchronous manner.
Resolution
Asynchronous Email Triggers
Interview Assessment Outstanding: This job runs once-a-day @ 6am server time/every day. (See Note 2269772)
Requisition Posting Expiration Upcoming: This job runs twice-a-day @ 6am & 6pm server time/every day. (See Note 2144747)
Requisition Posted: This job runs twice-a-day @ 8am & 8pm server time/every day. (See Note 2122640)
Synchronous Email Triggers:
(a) Application Updated by Recruiting Operator:
Trigger Point: Login as a Recruiting Operator and update the application of any candidate. Click on 'Save'.
NOTE: The Trigger is invoked whenever any application field or candidate profile field is edited and clicked on 'Save' button. Updating Resume or Cover Letter also sends a separate trigger email. Updating other additional attachments currently do not trigger this email.
(b) Requisition Re-opened:
Login as a Requisition Operator and open any of the closed Requisitions.
Trigger Point: Click on "Reopen Requisition" button (if permission exists).
NOTE: The Trigger is invoked even if the job requisition is reopened via SFAPI.
(c) Welcome / Thanks for Creating Account Email:
Open the company career site and follow the steps to create a new external account.
Trigger Point: Click on "Create Account" after filling all the fields in the registration page. If email verification is involved, click on the verification link from the email received.
NOTE: The trigger email is not sent for manually added candidates or imported candidates or agency-added candidates. Also, this trigger is applicable only for external candidate account creation.
(d) Agency User Re-Activated:
Provisioning -> Enable Agency-related switches
Admin Tools -> Click 'Set Up Agency Access'
Trigger Point: Click on an existing agency user & activate/enable the user (if disabled). Click on 'Save'.
NOTE: The trigger email is sent only to the External Recipient. Additional recipients cannot be configured in trigger or sent email.
(e) Requisition Closed:
Login as a Requisition Operator and open any of the open Requisitions.
Trigger Point: Click on "Close Requisition" button (if permission exists).
NOTE: The Trigger is invoked even if the job requisition is closed via SFAPI.
NOTE: Customs tokens configured to pull information from the Job Requisition status will considered the Job Req status before the same is closed.
(f) Requisition Changed :
Login as a Requisition Operator and open any Requisition, preapproved or approved.
Trigger Point: Make some updates to the Requisition and click on 'Save Changes' button or 'Save and Close' button (if permission exists).
NOTE: The Trigger is invoked even if the job requisition is changed via SFAPI. However, if status change (close or reopen) happens in the same Update, then this trigger email is not sent.
(g) Offer Received An Approval:
Provisioning -> switch on "Enable Offer Approval"
From Candidate Workbench, setup Offer Approval for an applicant.
Trigger Point: When an approver in the process approves the offer, it moves to the next approver in the chain.
NOTE: Document Routing Notification emails setup for the Offer Approvals are also sent independent of this trigger
(h) Offer Initiated (Sent For Approval):
Provisioning -> switch on "Enable Offer Approval"
From Candidate Workbench, setup Offer Approval for an applicant.
Trigger Point: When the offer is initiated for the first time, the defined recipients will receive an email.
NOTE: Document Routing Notification emails setup for the Offer Approvals are also sent independent of this trigger
(i) Interview Invite Failure Notification to Organizers:
Trigger Point: When the interview invite mail fails to be delivered
The organizer will receive a notification (template must be created) waring that the invite failed to be delivered.
NOTE: will only work with Interview Scheduling and Outlook Integration
*Please note that it is not possible to trigger any emails using a Recruiting Business Rule.*
Keywords
KBA , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-EML , Recruiting Emails and Notifications , How To