Symptom
When searching for user, 'No Data' is shown in dropdown of employee fields l
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- User has permission to view the field (Eg: Manager field, Job Relationship Name etc.)
- When trying to search for user >"No Data" is shown
Cause
- In Admin Center > Company System and Logo Settings, there is a feature "Enable target group based filtering for Worker fields"
- If enabled, Worker type fields value dropdown list will based on the target group settings in role based permission.
- If not enabled, all users will be available in the dropdown list.
Resolution
- Check on Admin Center > Company System and Logo Settings that the feature "Enable target group based filtering for Worker fields"
- If checked, Worker type fields value dropdown list will based on the target group settings in role based permission.
- If not checked, all users will be available in the dropdown list.
- Navigate to Permission role > Select the role of the affected user.
- Click Permission and scroll down to 'Manage User' > 'Restrict fields of type Worker'
Result:
The manager's access is restricted according to their Target population.
Keywords
Employee Central, auto delegation , permission, Restrict Worker, no data, user search permission, user search, unable to search, user field, worker, field permission, restrict search, target population, worker, HRIS_FINDUSER, manager, name, job relationship, supervisor, employee, Enable target group based filtering for Worker fields , KBA , LOD-SF-EC-RBP , Roles & Permissions (EC Core only) , LOD-SF-EP-UI , People Profile UI (PP3 UI) , LOD-SF-EC-JRL , Job Relationships , LOD-SF-EC-JOB , Job Information , Problem
Product
Attachments
| NoData.png |
| NoData.png |
SAP Knowledge Base Article - Public