SAP Knowledge Base Article - Public

2517486 - Account Field Update Worflow Rule with Sales Data Conditions Does Not Work

Symptom

You defined a workflow rule to update a field in an Account. The conditions maintained are changes in any field from Account Sales Data view.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Select the Workflow Rules View.
  3. Click in the New button.
  4. Select Account from the dropdown menu in the Business Object field.
  5. Click Next button.
  6. Click in Add Group button.
  7. In the Edit Condition pop-up, select any Sales Data field in the Field dropdown menu.
  8. Set other fields as desired and click OK button.
  9. Click Next button.
  10. Select Field Update from the dropdown menu in the Action field.
  11. Click Next button.
  12. Click Activate button.
  13. Go to the Account work center.
  14. Open an Account ABC (where ABC represents the ID of the Account).
  15. Edit a field on Sales Data view.

You expect that your change on a Sales Data field would trigger the field update on the respective Account.

Cause

Workflow rules work only for the business object defined on the step 1 of its definition (in this case Account). The information from Sales Data is in a different entity (technically other business object) than Account.

Resolution

This is the system standard behavior. A possible workaround is to create an extension field on Account and change its value every time a change the for the Sales Data field happens. This should trigger the workflow rule.

IIf the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

Account, Field, Update, Workflow, Rule, Sales, Data, Conditions, Not, Work, Working , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer core applications all versions