Symptom
You defined a workflow rule to update a field in an Account. The conditions maintained are changes in any field from Account Sales Data view.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Select the Workflow Rules View.
- Click in the New button.
- Select Account from the dropdown menu in the Business Object field.
- Click Next button.
- Click in Add Group button.
- In the Edit Condition pop-up, select any Sales Data field in the Field dropdown menu.
- Set other fields as desired and click OK button.
- Click Next button.
- Select Field Update from the dropdown menu in the Action field.
- Click Next button.
- Click Activate button.
- Go to the Account work center.
- Open an Account ABC (where ABC represents the ID of the Account).
- Edit a field on Sales Data view.
You expect that your change on a Sales Data field would trigger the field update on the respective Account.
Cause
Workflow rules work only for the business object defined on the step 1 of its definition (in this case Account). The information from Sales Data is in a different entity (technically other business object) than Account.
Resolution
This is the system standard behavior. A possible workaround is to create an extension field on Account and change its value every time a change the for the Sales Data field happens. This should trigger the workflow rule.
IIf the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
Account, Field, Update, Workflow, Rule, Sales, Data, Conditions, Not, Work, Working , KBA , LOD-CRM-WKF , Workflow , How To