SAP Knowledge Base Article - Public

2518070 - Referrer is not receiving emails when referred candidate is moved through the candidate pipeline

Symptom

The Referrer is not getting an email when a referral candidate is submitted and moved through the pipeline. The Candidate receives an email but the referrer does not.

 Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

Prerequisites:

  1. Employee referral is correctly set up in the Production system as per all the requirements.
  2. In the recruiting email triggers, all the 3 triggers related to Employee referral should be enabled with all the valid Tokens, for the trigger to work.
     - Employee Referral Program Candidate added to General pool notification
     - Employee Referral Program Candidate referred to a job requisition (new candidate)
     - Employee Referral Program Candidate referred to a job requisition (existing candidate)
  3. In the Applicant status configuration, the referrer email is set up properly as below:

Refer a Candidate to a job requisition, notice that the candidate will receive emails related to referral but the referrer will not.

Cause

The candidate is technically a non-applicant until they actually apply to the requisition. Until they apply, they will be considered a forwarded candidate and the referrer will not receive the email notification when the candidate is moved through the pipeline.

Resolution

While the referred candidate remains a non-applicant, changes to their applicant status will not trigger any email to the referrer.

This is an expected behaviour.

Keywords

Referee, E-mail, E mail, Edit Applicant Status Configuration, , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , How To

Product

SAP SuccessFactors Recruiting all versions