SAP Knowledge Base Article - Public

2518498 - Notification: Image added in template is not working

Symptom

An image was added to a notification template using the "Insert Image" option in the "Notification Editor" and it was provided the link of the image (ex.: Google Drive). However, when the email is triggered to the users, the image doesn't load.


Email-Image.png

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Learning Administration > System Administration > Manage Email > Email Notification Template >
  2. Search and access the desired template >
  3. "Message" tab > Click "Launch Editor" link >
  4. Click "Insert Image" > Provide the source path and dimensions > Save the changes.

email-Image1.png

Cause

The link added to the template doesn't have any extension at the end of the link due to which it won't work. The image path should always end like .JPG, .JPEG, .PNG.

Resolution

For images to load fine in the email, it's required to provide the full path containing the extension of the image. Place the file in a server where it can be accessed using the full path.

Ex.: http://www.******.com/image.png (where ****** is the server in which the image is stored in).

Follow the steps mentioned in the "Reproducing the issue" section and update the "Source" via the "Insert Image" option with the full path.

IMPORTANT: The image URL being added to the notification template should be publicly hosted on the internet, not just on the local system. It should be accessible without asking for any credentials. More details about it at KBA 2258281.

See Also

Keywords

successfactors, learning, email, notification, template, editor, image, logo, link, not, load, loading, error, added, add, picture , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions