Symptom
When creating a new sales document, the following error message is triggered: 'You can't copy the document, because reference document is inconsistent.'.
Environment
SAP Cloud for Customer
Reproducing the Issue
The following steps are only an example. The same behaviour can happen from other views.
- Go to the Service work centre.
- Go to the Tickets view.
- Open ticket ID ABC (ABC represents the ticket ID).
- Go to the Related Items facet.
- In the Follow-up Items section select the Actions icon.
- Select Create Opportunity.
RESULT: The error message 'You can't copy the document, because reference document is inconsistent.' is triggered.
This error can also happen when creating a copy of a sales document (for instance, a lead).
Cause
There is no account/individual customer maintained for the object ABC (i.e Ticket in the above example).
Resolution
Once an account/individual customer has been maintained for the object ABC, the error message will not longer be triggered.
In the previously mentioned example, we would do:
- Go to the Service workcenter.
- Go to the Tickets view.
- Open ticket ID ABC.
- Choose the value help of the Customer field.
- Select an account from the and click Save.
Keywords
Ticket, Follow Up, lead, Opportunity, Sales Quote, sales order, Inconsistent, reference document , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-SRP , Service Request Processing , How To