Symptom
Country-specific field Account Type, for example Account Type (USA) is not appearing when adding Payment Information details for USA users in the UI. However, the field appears for the same employee when adding the details through Manage Data.
Environment
Employee Central: Payment Information
Cause
There is a UI rule, which is responsible for the visibility of this field.
In this rule, you need to reselect the value in the IF condition to activate it.
Resolution
We need to refresh the UI rules, otherwise they don't work. It needs to be done only once.
The below example is for USA, but can be applied to any country and country specific UI rule:
- Navigate to Admin Centre -> Manage Configuration UI
- Search for the UI that is being used for Payment Information
- Hover the mouse over "Payment Information" and click on Manage UI Rules
- Click on the rule "USA"
- Click on the drop down where "USA" is displayed
- Manually search and re-select USA
- Click on Save
- Repeat the steps 4-7 for other UI rules and refresh all of them
- Once all the UI rules are refreshed, click on Close -> Save (in the Manage Configuration UI screen)
Keywords
csf, country-specific, country specific, rule, UI, refresh, account type, missing, payment info , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , LOD-SF-EC , Employee Central , Problem