Symptom
User has scheduled a Report in the Reports section of the LMS. After the report has run the report is available in the report jobs menu.
However, when the user searches for that job in Background Jobs (System Administration > Background Jobs menu), the report does not appear.
Environment
SuccessFactors Learning Management System (LMS) - All Supported Versions
Reproducing the Issue
-
Schedule a report in the Reports section by accessing the report and clicking the Schedule Job button.
- Allow the report to run.
- After the report has run try to view the report in Background Jobs. The Report does not appear here.
Cause
Not all reports will be available to be viewed in the Background Jobs section.
Resolution
Internally there are three type of report jobs, as listed below -
Report – If Admin schedules a report from "Schedule Job" option from the report detail screen
ImmediateReport -- If Admin schedules a report from "Run Report" option from the report detail screen
RecurringReport – If Recurring Report is configured.
The Background Job search screen will show only the report jobs from "Schedule Job" option. This is as designed. The other report types will not be available in the Background Job search.
Keywords
scheduled a report, Background Jobs, Report, ImmediateReport, RecurringReport, Schedule Job , KBA , LOD-SF-LMS-BCJ , Assign (bulk), Add/ Delete Sub/ Cur, Revise, Import , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-REP , Reporting Data , Problem