Symptom
Associated Ticket field is blank for this e-mail activity generated, although there is a Ticket linked to the Email under the Related Items facet.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Activity work center;
- Go to E-mails view;
- Search for E-mail 123 (123 represents the e-mail ID);
- The field Associated Ticket is blank.
Cause
Whenever an e-mail activity is created through any automatic method (e.g Workflow rule, Data Workbench) the reference to the source object ( Ticket/Opportunity/Leads...) is never created.
Resolution
This is the system expected behavior.
The field works in a way that it is populated only when the Tickets are created via Email Channel. On those occasions, there is a link between that Email and the Ticket, on the system backend, call Initiating UUID. This link is passed on to all other emails from the thread then, but it initiates on the first email.
Keywords
KBA , LOD-CRM-SC-EML , Email , How To