Symptom
"An error occured. Please try again later." error message is shown when submitting leave of absence request
Environment
- SAP SuccessFactors Employee Central Time Off
- v12 / People Profile (PP3)
Reproducing the Issue
1. Go to Time Off section in People Profile then click Administer Time link.
2. Under Time records tab, click on New Absence button.
3. Select a Leave of Absence time type and select the dates for the absence(s).
4. Click Submit. An error message is shown by the system.
Cause
Employee Status picklist is not maintained properly
Product Support: See internal memo for sample logs
Resolution
Maintain correct external codes for the employee-status picklist through Picklist Center if picklists have been migrated to MDF or Picklist Management if still using the legacy CSV picklists.
Updating Picklist via Picklist Center
1. Go to Admin Center > Picklist Center.
2. Search for employee-status then click on Make Correction.
3. In External Code and Non-Unique External Code, maintain the values as follows.
4. Save the changes to the picklist.
Updating Picklist via Picklist Management
1. Go to Admin Center > Picklist Management.
2. Select Export all picklist(s) option an uncheck 'Include System Generated Job Codes' and set Character Encoding to UTF-8 then click Submit.
Once picklist export has completed, click on Download Export button.
3. Open the file in Excel / Open Office and filter the records by picklist id 'employee-status' then maintain external codes as follows:
Once the external codes are maintained, remove all the other picklist records and ensure that only the employee status picklist is in the file.
4. Reimport the picklist into the system.
Keywords
"An error has occured, please try again", Time Off for Leave of Absence, LOA, time type, employee status, picklist, leave of absence , KBA , LOD-SF-EC-TIM , Time Off , LOD-SF-EC , Employee Central , Problem