SAP Knowledge Base Article - Public

2521079 - Error: 'Invalid date format' when refreshing a report based off Salesforce.com Command Object in Crystal Reports

Symptom

  • Error: 'Invalid date format'
  • Reports based off Salesforce fails in Crystal Reports.
  • After applying a product update, report based off Salesforce.com Command Object fails in Crystal Reports with the error:
         
         Failed to retrieve data from the database.
         Details: 22007:[Simba][Support] (40481) Invalid date format for ‘’.
         The format should be [-]YYYY-MM-DD. [Database Vendor Code: 40481 ] 
       
    or the error message:
          
         Database Connector Error: ‘22007:[DSI] The error message InvalidDateFormat could not be found in the en-US localed.

Environment

  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016

Reproducing the Issue

  1. In Crystal Reports, create a report off Salesforce.com using a Command Object.
  2. In the Command Objects enter a SQL Query or SOQL Query
  3. Add at least one database field to the report.
  4. When refreshing the report, it fails with the error:
                   
         Failed to retrieve data from the database.
         Details: 22007:[Simba][Support] (40481) Invalid date format for ‘’.
         The format should be [-]YYYY-MM-DD. [Database Vendor Code: 40481 ] 

Cause

  • The issue occurs with the latest update of the SAP Salesforce ODBC Driver version 1.02.07.1019 which is bundled in the following version of Crystal Reports and above:
    • Crystal Reports 2013 - SP09
    • Crystal Reports 2016 - SP04
           
  • The issue has been tracked under SAP Note 2521442

Resolution

  • The issue is resolved in the following product update, and above:
        
    • Crystal Reports 2013 - Support Pack 11
    • Crystal Reports 2016 - Support Pack 06
         
                 
  • To workaround the issue, downgrade your version of Crystal Reports to a version that have a lower version of the SAP Salesforce ODBC driver. The version of Crystal Reports below are using version 1.01.29.1032 of the ODBC Driver where the issue does not exist, and are connecting to Salesforce.com using TLS 1.2
         
    • Crystal Reports 2013 - Support Pack 06 - Patch 6     
    • Crystal Reports 2016 - Support Pack 03

Keywords

CR, Sforce , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports all versions