SAP Knowledge Base Article - Public

2521309 - Partner Contact Selection in Opportunity

Symptom

You are able to save the partner contact which is not associated to the selected partner.

Reproducing the Issue

  1. Go to the Sales work center.
  2. Select Opportunities view.
  3. Open any opportunity.
  4. Go to the Involved Parties facet.
  5. Add a new Partner.
  6. Click on the Name value help and select the partner ABC (ABC represents the partner ID).
  7. Click on the Partner Contact value help and select one of the displayed partner contacts.
  8. Click again on the Name value help and select the partner DEF.
  9. Click on Save.

Cause

This is the expected system behaviour.

Resolution

Currently there is no check to see if the contact is linked with the related party. For example, it is also possible to attach a contact which is not part of the account in an opportunity. The same behaviour exists for partner and partner contact.

If a hard check is required, you can implement this via PDI.

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Hybris Cloud for Customer add-ins 1708