Symptom
Error upon Previewing Attachment in Registered Products Facet of Customer Work Center View.
Reproducing the Issue
- Go to the Customers workcenter.
- Go to the Account view.
- Go to Customer XYZ.
- Go to Registerd Product Facet of the Cutsomer XYZ.
- Go to Registered Product ABC.
- Go to Attachments of the Registered Product ABC.
- Please add an Attchment to this Registerd Product ABC.
- After adding an image as an Attachment, click save.
- Now click on Actions and then on Preview.
Cause
- If application doesn’t pass Country Code, then framework is checking the logged in User’s Org and its Company Country.
- And then checking for a form which is maintained for that Country.
- By default only one Standard Form for US and EN is provided. The issue is due to form not available in the country that you have scoped your system in.
Resolution
- Go the the Organizational Management Work Center.
- Go to Org Structure Work Center View.
- Open any Org unit where its default Country is the same as the one scoped in your system.
- Go to Employees facet.
- Assign the Customer’s logged in user to the list. (User who is trying to preview the attachment and experiencing this issue).
- Make sure in Business Configuration, scope in Country is the same as the above in step 3.
- Also, please scope Country :United States and save the same.
- Go to Application and User Management Work Center.
- Go to Form Template Maintainance Work Center View.
- Search for Form with search criteria Template Group: A02-Registered Product.
- Select the Form which is with Country: United States and Language: English
- Click on Copy and select "As New Variant".
- Choose default Country in which your system is scoped and Language: English. Click Ok.
- Now in Business Configuration you can remove the scope in Country: United States and keep only default Country in which your system is scoped.
- Now open any Registered Product instance and click on preview, the form will be Previewed without any error.
Keywords
KBA , LOD-CRM-ACC , Account , How To
Product
SAP Cloud for Customer core applications 1708 ; SAP Cloud for Customer core applications 1711 ; SAP Hybris Cloud for Customer add-ins 1708