SAP Knowledge Base Article - Public

2521411 - Error upon Previewing Attachment in Registered Products in Customers

Symptom

Error upon Previewing Attachment in Registered Products Facet of Customer Work Center View.

Reproducing the Issue

  1. Go to the Customers workcenter.
  2. Go to the Account view.
  3. Go to Customer XYZ.
  4. Go to Registerd Product Facet of the Cutsomer XYZ.
  5. Go to Registered Product ABC.
  6. Go to Attachments of the Registered Product ABC.
  7. Please add an Attchment to this Registerd Product ABC.
  8. After adding an image as an Attachment, click save.
  9. Now click on Actions and then on Preview.

Cause

  1. If application doesn’t pass Country Code, then framework is checking the logged in User’s Org and its Company Country.
  2. And then checking for a form which is maintained for that Country.
  3. By default only one Standard Form for US and EN is provided. The issue is due to form not available in the country that you have scoped your system in.

Resolution

  1. Go the the Organizational Management Work Center.
  2. Go to Org Structure Work Center View.
  3. Open any Org unit where its default Country is the same as the one scoped in your system.
  4. Go to Employees facet.
  5. Assign the Customer’s logged in user to the list. (User who is trying to preview the attachment and experiencing this issue).
  6. Make sure in Business Configuration, scope in Country is the same as the above in step 3.
  7. Also, please scope Country :United States and save the same.
  8. Go to Application and User Management Work Center.
  9. Go to Form Template Maintainance Work Center View.
  10. Search for Form with search criteria Template Group: A02-Registered Product.
  11. Select the Form which is with Country: United States and Language: English
  12. Click on Copy and select "As New Variant".
  13. Choose default Country in which your system is scoped and Language: English. Click Ok.
  14. Now in Business Configuration you can remove the scope in Country: United States and keep only default Country in which your system is scoped.
  15. Now open any Registered Product instance and click on preview, the form will be Previewed without any error.

Keywords

KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer core applications 1708 ; SAP Cloud for Customer core applications 1711 ; SAP Hybris Cloud for Customer add-ins 1708