Symptom
- Deleted form data such as ratings, form dates, comments, and custom field values are not pulling up when using Ad hoc Reports for Performance Management.
- How to report on deleted form data?
Environment
- SAP SuccessFactors Performance Management
- SAP SuccessFactors Reporting & Analytics
Reproducing the Issue
- Launch a new form and enter comments and ratings in the form.
- Delete the form.
- Create PM ad hoc report and notice that deleted form will not pull any data in the report.
Cause
- This is the system expected behavior.
- The AdHoc report is reading data from feedback table, but once the form is deleted, the content in the feedback table is also deleted.
Resolution
The deleted form data can be extracted via Detailed Document Search report.
To access it you can follow the steps below:
- Log to the instance;
- Go to Reporting module;
- Search for 'Classic Reporting' and Select Detailed Document Search.
If you'd like to report on the data using AdHoc reports, then the form has to be restored.
To restore a PM form you can follow the steps below
- Log to the instance;
- Go to Admin Center;
- Search for 'Restore Deleted Forms'
- Follow the instructions on the screen.
See Also
KBA 2230818 - Performance management Adhoc Report-Ratings are not reportable once inactive users forms are deleted
Keywords
deleted form report, ad hoc report deleted form , KBA , csg_q , LOD-SF-PM-REP , Reporting & Analytics, Data Imports & Exports , Problem
Product
SAP SuccessFactors Performance & Goals all versions