Symptom
Any Activity linked to an Account is going to be assigned to the first Sales Organization in the Sales Data facet of the Account.
Reproducing the Issue
Prerequisite: You have maintained an account ABC (ABC is the name of the account) with multiple Sales Organizations.
1. Go to the Activities work center.
2. Go to the Appointments view (it also works for any other activity linked to an account: Tasks, Phone Calls...).
3. Click new and create an Appointment and select an Account ABC.
4. Save and Open the Appointment.
5. The first Sales Organisation in the Sales Data facet of the Account has been assigned as the Activity Sales Organization.( Please keep in mind that this is an arbitrary choice, and the sequence is irrelevant; the second Sales organization may have been chosen as well.)
Cause
This is the expected system behaviour.
Resolution
After the Activity has been created, you can manually change the Sales Organization following these steps:
1. Open the Appointment.
2. Click Edit.
3. Click on the Value Selection next to Sales Organization.
4. Select the Sales Organization that you want to assign to this account.
5. Click Close.
-> The new Sales Organisation has been assigned to this Account.
6. Save the Appointment.
Keywords
KBA , LOD-CRM-EMP , Employee , Product Enhancement