Symptom
As Key User, you are not able to assign a User as responsible of a Business Role.
Reproducing the Issue
1. Go to Application and User Management Work Center;
2. Select Business Role Sub View;
3. Edit Business Role ´ABC´;
4. Then click on Add Row under Users Responsible;
5. Search for the User;
6. Not able to find the User;
7. No further error is showing.
Cause
This is a normal system behavior and this occurs because the user is not assigned to the following views:
1. Work Center View ID: IAM_BUSINESSROLE
2. Work Center View ID: ADMOPSWCV
3. Work Center View ID: SEOD_ADMIN_SETUP_WCVIEW
Resolution
1. Go to Application and User Management Work Center
2. Select Business User Sub View
3. Search for the User
4. Click on Edit
5. Then Access Rights
6. Go to Work Center and View Assignment Tab
7. Search for IAM_BUSINESSROLE
8. Assign Work Center View ID: IAM_BUSINESSROLE under Work Center ID: ITS_APPLICATIONUSERMANAGEMENT
9. Search for ADMOPSWCV
10. Assign Work Center View ID: ADMOPSWCV under Work Center ID: ADMINWCF
11. Search for SEOD_ADMIN_SETUP_WCVIEW
12. Assign Work Center View ID: SEOD_ADMIN_SETUP_WCVIEW under Work Center ID: SEODADMINWCF
13. Save the changes
14. Now, you are able to find the User when searching for it under Users Responsible of the Business Role.
Keywords
KBA , LOD-LE-BP-BP , Business Partner , How To