Symptom
You have executed a profitability report with service order ID characteristic, however you notice that, for some entries in the fiscal year, the ID is either in blank or has '#' (Not Assigned).
Reproducing the Issue
- Go to Business Analytics work center.
- Go to Design Data Sources view.
- Show All and Find FINPRFU01 (Profitability : Order Profit).
- Click on Preview button.
- Move Customer, Associated Service Order ID and Fiscal Year characteristics from Not Currently Shown section to Rows.
For a specific customer, you notice that the Associated Service Order ID shows in blank or '#' Not Assigned for e.g. fiscal year 2016.
Cause
The reason why the field is in blank/# for the fiscal years is because those rows belong to other objects and not service orders. This data source shows everything, Sales Order, Service Orders, Contracts, etc. Some of those items actually belong to Sales Orders and not Service Orders.
Resolution
In order to properly distinguish the documents in the data source, you may include further characteristics such as the Associated Sales Order ID. Hence, the #-Not Assigned entry for the Associated Service Order ID would have an ID under Associated Sales Order ID if the document is a sales order.
Keywords
KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To